Browsed by
Month: July 2005

CSS with Google Cache shows up Black

CSS with Google Cache shows up Black

I have had issues with Google’s cache of my site since I switched to CSS. After some searching I discovered that it is not google as much as it is Microsoft Internet Explorer. For some reason if you have html before the head tag it will cause errors with the background color tag in CSS.

Since I did not need the background color changed I removed the attribute from the CSS file and it cleared the color problem in Google’s cache immediatly. There are still some issues with div positions but I can live with that.

I have also added Google Adsense ads to the page. It required a slight page modification but nothing that I think looks to bad. In turn it will help me pay for the overhead while I have no income.

Tk804 and TableMatrix 1.2 Works!

Tk804 and TableMatrix 1.2 Works!

To celebrate I decided it was time for a new perl image.

I listened to John?Cerney and I went to the Univ of Winnipeg repository and downloaded Tk804.026 and TableMatrix 1.2 and it works perfectly. I am still running perl 5.8.3 because I saw no need to tempt fate with another update that could cause a different error.

I think the solution is that the Univ of Winnipeg site compiled TableMatrix 1.2 with Tk804, so you should only need to download TableMatrix but I got Tk804 from them as weel just to be sure. Hopefully this will solve other people problems out there.

TableMatrix and Tk804 still Unresolved

TableMatrix and Tk804 still Unresolved

I got a response back from John Cerney, who is the creator of the TableMatrix module, this morning. He says that TableMatrix has been compatible with Tk804 since TableMatrix v1.1.

However he did say that TableMatrix has to be recompiled with Tk804 in order for it to work with Tk804 so my thought is that maybe ActiveState is not compiling TableMatrix correctly with Tk804 and is reusing a compile version from Tk800. I am going to see if other repositories have versions that work.

The rub is that now I have to have two parrallel versions of perl running on my machine. Version 1 with Tk800 that works for continued development. And Version 2 with Tk804 to test different versions of TableMatrix 1.2.

Perl Tk TableMatrix Update

Perl Tk TableMatrix Update

I had previously posted some issues I have been having with the TableMatrix module for Perl Tk. I had assumed that the errors were with ActiveState’s version of perl. But I have discovered that TableMatrix is not compatible with Tk-804. TableMatrix 1.2 causes an error in widget.pm on line 190. It appears that it is expecting a reference to a hash and is being passed a reference to something else.

Does anyone know what the change was in Tk-804 that would cause TableMatrix to break and possibly how to fix it? I sent a note to the creater on CPAN but have not had any response yet. Thanks all.